A Major vulnerability which is almost a decade old is found in Intel processors manufactured in this decade. It leaves a massive security hole in all the devices across the platforms using the affected processors. It means virtually all the devices using Intel processors made in the last decade are affected.

This flaw allows “normal user programs- from database applications to simple javascript in browsers” to access protected memory areas in the kernel.

Severe Effects?

This severe bug, caused by the design defects of Intel processors can’t be patched by a firmware update, it needs an Operating system patch i.e it needs a patch on Windows, Linux and Mac. If the reports are correct this patch could potentially slow down your PC by 5 to 30 % as the patch requires to serve kernel memory from the user processes.

Even though normal users won’t find much change in the performance of their devices.  Cloud services and large business are going to have the biggest performance hit and may lose a lot of processing power at their backend.

The patches might be further updated to increase the efficiency, but for now, it appears that the performance slowdown is unavoidable.

And there is no such vulnerability is found in AMD processors.

What do you think about the latest flaw found in Intel chipsets? Let us know in the comments below.